zpět na výpis    domů » excel » Textová funkce OPAKOVAT()

Textová funkce OPAKOVAT()

Publikováno: 28.4.2019

Textová funkce OPAKOVAT()

V dnešním článku si představíme velmi jednoduchou, ale přesto užitečnou funkci OPAKOVAT() ve dvou praktických aplikacích. Nutno podotknout, že je to spíše funkce pro "hračičky". První aplikací je zvýraznění buňky či hodnoty v buňce vybranými znaky. A na závěr si vytvoříme vlastní pruhový graf, který můžeme umístit do libovolné buňky.

Funkce OPAKOVAT()

Funkce patří do kategorie textových funkcí. Obsahuje dva parametry pro zadání textu určeného k opakování a počtu opakování vybraného znaku. Text můžeme nahradit libovolným znakem.

=OPAKOVAT(text; počet)

Smyslem funkce je vyplnit buňku zvoleným znakem v požadovaném počtu.

Připojení znaků k obsahu jiné buňky

Někdy je užitečné přidat k hodnotě v buňce určitý znak(y). Například mohou být přidány znaky pro zvýraznění hodnoty v buňce a buňky samotné. Přidání znaků k obsahu buňky A1 se zapisuje jako

=OPAKOVAT("znak"; počet)&" "&A1

Spojování funkce a řetězců se provádí pomocí znaku &. Text a mezera se vkládá mezi uvozovky &"text"& a &" "&.

V následující úloze jsou připojeny 3 znaky "=" zleva i zprava k číselné hodnotě

Obalení znakem pomocí funkcí OPAKOVAT() v MS excelu

Vlastní graf pomocí funkce

Dalším způsobem využití funkce OPAKOVAT() je tvorba dynamického pruhového grafu bez použití Průvodce grafem. V této části si ukážeme dva příklady. První příklad je technicky identický s předchozím použitím funkce. Druhý příklad je složitější kvůli použití více funkcí v jednom zápisu.

Graf #1

K dispozici máme tabulku se mzdami zaměstnanců, které chceme pro přehlednost zobrazit graficky v buňkách vedle mezd. Pro zvýšení komfortu uživatele a celkový grafický dojem snížíme mzdu každého zaměstnance tisíckrát.

=OPAKOVAT("|"; C5/1000)

V buňce D5 odkazujeme na mzdu v buňce C5, která je snížena tisíckrát. Protažením vzorce ve sloupci D dolů získáme grafické vyjádření pro všechny mzdy.

Obalení znakem pomocí funkcí OPAKOVAT() v MS excelu

Graf #2

Dalším příkladem grafu může být rozdělení mezd na nadprůměrné a podprůměrné mzdy. Nadprůměrnou mzdu vyhodnotíme podmínkovou funkcí KDYŽ() následovně

=KDYŽ(C5>PRŮMĚR($C$5:$C$12);OPAKOVAT("|"; C5/PRŮMĚR($C$5:$C$12)*10);" ")

Je-li mzda v buňce C5 vyšší než vypočtený aritmetický průměr, tak funkce OPAKOVAT() vypíše znak | jako násobek průměrné mzdy. Pro lepší grafický dojem zvýšíme násobek desetkrát.

Pro identifikaci podprůměrných mezd pouze změníme znaménko v podmínce funkce KDYŽ() a zarovnáme hodnoty v buňce doprava

=KDYŽ(C5<PRŮMĚR($C$5:$C$12);OPAKOVAT("|"; C5/PRŮMĚR($C$5:$C$12)*10);" ")

Obalení znakem pomocí funkcí OPAKOVAT() v MS excelu

Líbí se vám článek a chcete vědět o každém dalším? Dejte Like Financím v praxi na sociálních sítích.

Google+

Sdílejte článek na sociálních sítích

Nahoru